Routing Information Protocol
Routing Information Protocol (RIP) is one of the oldest distance vector routing protocols, which employs the hop count as a routing metric. RIP prevents routing loops by implementing a limit on the number of hops allowed in a path from the source to a destination.
RIP CONFIGURATION
Router1
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R1
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 10.0.0.1 255.0.0.0
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1(config-if)#exit
R1(config)#interface serial 2/0
R1(config-if)#ip address 192.168.1.1 255.0.0.0
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial2/0, changed state to down
R1(config-if)#exit
R1(config)#router rip
R1(config-router)#network 10.0.0.0
R1(config-router)#network 192.168.1.0
R1(config-router)#exit
R1(config)#exit
R1#
Router2
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R2
R2(config)#int fastEthernet 0/0
R2(config-if)#ip address 11.0.0.1 255.0.0.0
R2(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R2(config-if)#exit
R2(config)#interface serial 2/0
R2(config-if)#ip address 192.168.1.2 255.255.255.0
R2(config-if)#no shutdown
R2(config)#interface serial 3/0
R2(config-if)#ip address 192.168.2.1 255.255.255.0
R2(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial2/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up
R2(config-if)#exit
R2(config)#router rip
R2(config-router)#network 11.0.0.0
R2(config-router)#network 192.168.1.0
R2(config-router)#network 192.168.2.0
R2(config-router)#exit
R2(config)#exit
R2#
Router3
Router>enable
Router#configure termina
lEnter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R3
R3(config)#interface fastEthernet 0/0
R3(config-if)#ip address 12.0.0.1 255.0.0.0
R3(config-if)#no shutdown
R3(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R3(config-if)#exit
R3(config)#interface serial 3/0
R3(config-if)#ip address 192.168.2.2 255.255.255.0
R3(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial3/0, changed state to up
R3(config-if)#exit
R3(config)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/0, changed state to up
R3(config)#router rip
R3(config-router)#network 12.0.0.0
R3(config-router)#network 192.168.2.0
R3(config-router)#exit
R3(config)#exit
R3#
VERIFICATION
Go to any pc & ping to another pc's
Pinging 12.0.0.1 with 32 bytes of data:
Reply from 12.0.0.1: bytes=32 time=60ms TTL=253
Reply from 12.0.0.1: bytes=32 time=40ms TTL=253
Reply from 12.0.0.1: bytes=32 time=40ms TTL=253
Reply from 12.0.0.1: bytes=32 time=40ms TTL=253
Routing Information Protocol (RIP) is one of the oldest distance vector routing protocols, which employs the hop count as a routing metric. RIP prevents routing loops by implementing a limit on the number of hops allowed in a path from the source to a destination.
RIP CONFIGURATION
Router1
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R1
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 10.0.0.1 255.0.0.0
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1(config-if)#exit
R1(config)#interface serial 2/0
R1(config-if)#ip address 192.168.1.1 255.0.0.0
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial2/0, changed state to down
R1(config-if)#exit
R1(config)#router rip
R1(config-router)#network 10.0.0.0
R1(config-router)#network 192.168.1.0
R1(config-router)#exit
R1(config)#exit
R1#
Router2
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R2
R2(config)#int fastEthernet 0/0
R2(config-if)#ip address 11.0.0.1 255.0.0.0
R2(config-if)#no shutdown
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R2(config-if)#exit
R2(config)#interface serial 2/0
R2(config-if)#ip address 192.168.1.2 255.255.255.0
R2(config-if)#no shutdown
R2(config)#interface serial 3/0
R2(config-if)#ip address 192.168.2.1 255.255.255.0
R2(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial2/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up
R2(config-if)#exit
R2(config)#router rip
R2(config-router)#network 11.0.0.0
R2(config-router)#network 192.168.1.0
R2(config-router)#network 192.168.2.0
R2(config-router)#exit
R2(config)#exit
R2#
Router3
Router>enable
Router#configure termina
lEnter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R3
R3(config)#interface fastEthernet 0/0
R3(config-if)#ip address 12.0.0.1 255.0.0.0
R3(config-if)#no shutdown
R3(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R3(config-if)#exit
R3(config)#interface serial 3/0
R3(config-if)#ip address 192.168.2.2 255.255.255.0
R3(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial3/0, changed state to up
R3(config-if)#exit
R3(config)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/0, changed state to up
R3(config)#router rip
R3(config-router)#network 12.0.0.0
R3(config-router)#network 192.168.2.0
R3(config-router)#exit
R3(config)#exit
R3#
VERIFICATION
Go to any pc & ping to another pc's
Pinging 12.0.0.1 with 32 bytes of data:
Reply from 12.0.0.1: bytes=32 time=60ms TTL=253
Reply from 12.0.0.1: bytes=32 time=40ms TTL=253
Reply from 12.0.0.1: bytes=32 time=40ms TTL=253
Reply from 12.0.0.1: bytes=32 time=40ms TTL=253
0 comments:
Post a Comment